易语言获取网页微信二维码

今天没事在研究网页版微信扫码登录,就用易语言随便写了一个微信网页版获取扫码登录的二维码。
源码仅仅只有获取二维码的功能,有兴趣的小伙伴可以自行扩展,源码需要搭配精易模块使用。

.版本 2
.支持库 internet

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕

微信_二维码 ()

.子程序 微信_二维码, , , 本命令由【精易网页调试助手】生成,请配合精易模块使用。
.局部变量 局_网址, 文本型
.局部变量 局_方式, 整数型
.局部变量 ADD_协议头, 类_POST数据类
.局部变量 局_提交协议头, 文本型
.局部变量 局_结果, 字节集
.局部变量 局_返回, 文本型
.局部变量 局_处理, 文本型

局_网址 = “https://login.wx.qq.com/jslogin?appid=wx782c26e4c19acffb&redirect_uri=https%3A%2F%2Fwx.qq.com%2Fcgi-bin%2Fmmwebwx-bin%2Fwebwxnewloginpage&fun=new&lang=zh_CN&_=1581656761647”
局_方式 = 0
ADD_协议头.添加 (“Accept”, “*/*”)
ADD_协议头.添加 (“Referer”, “https://wx.qq.com/”)
ADD_协议头.添加 (“Accept-Language”, “zh-CN”)
ADD_协议头.添加 (“User-Agent”, “Mozilla/5.0 (Windows NT 10.0; WOW64; Trident/7.0; rv:11.0) like Gecko”)
ADD_协议头.添加 (“Host”, “login.wx.qq.com”)
ADD_协议头.添加 (“Connection”, “Keep-Alive”)
ADD_协议头.添加 (“Cache-Control”, “no-cache”)
局_提交协议头 = ADD_协议头.获取协议头数据 ()
局_结果 = 网页_访问_对象 (局_网址, 局_方式, , , , 局_提交协议头, , , , , , , , , , , )
局_返回 = 到文本 (局_结果)
局_处理 = 文本_取出中间文本 (局_返回, #引号, #引号 + “;”)
图片框1.图片 = HTTP读文件 (“https://login.weixin.qq.com/qrcode/” + 局_处理)

文件下载

  文件名称:获取微信二维码.zip  文件大小:64KB
  下载声明:本站文件多来自于网络,仅供学习和研究使用,不得用于商业用途,如有版权问题,请联系本站!
  下载地址:百度云盘 提取码:fx1w

七彩云博客 , 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权
转载请注明原文链接:易语言获取网页微信二维码

您必须 登录 才能发表评论!