易语言组件抖动

易语言组件抖动

易语言组件抖动

今天来给大家分享一个易语言的源码,非常简单,如题所示,“易语言组件抖动”,类似于错误提示。

比如编辑框里的内容输入错误,可以抖动一下窗口或者其他组件来提示用户,代码如下:

.版本 2
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击

' 非原创,原创作者忘记了
.计次循环首 (5, ) ' 这里的5是抖动次数
 抖动 ()
 延迟 (50)
.计次循环尾 ()

.子程序 抖动, , , 其它控件也可以的
.局部变量 Num, 整数型
.局部变量 Time, 整数型

Num = 3
Time = 50
_启动窗口.左边 = _启动窗口.左边 - Num
延迟 (Time) ' 推荐api的延迟
_启动窗口.左边 = _启动窗口.左边 + Num

无需任何模块,也可以下载我打包好的源码。

文件下载

  文件名称:doudong.e  文件大小:97KB
  下载声明:本站文件多来自于网络,仅供学习和研究使用,不得用于商业用途,如有版权问题,请联系本站!
  下载地址:七彩云下载


七彩云博客 , 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权
转载请注明原文链接:易语言组件抖动

您必须 登录 才能发表评论!