此处广告位出售

解决易语言读取网页文本不换行

解决易语言读取网页文本不换行

今天来给大家说说,使用易语言在读取网页文本时,读取出来的内容不会自动换行的问题。

如下图所示,在网页访问时为左边所示,易语言读取出来后为右边所示:
解决易语言读取网页文本不换行

这里我采取的方式是使用易语言的”子文本替换”,接下来我们来看看具体代码如何写:

首先把从服务器(或其他)获取到的文本文件使用一个变量存起来(Ps:这里要注意的是,在服务器的文本中,每行的最后一个字后面添加一个需要被替换的字符,如:-,*,=,+等等);

使用易语言的”子文本替换”把获取到的文本中,你刚刚设置的替换符替换成换行符即可,下面上代码:

.版本 2
.支持库 internet

.程序集 窗口程序集_启动窗口
.程序集变量 获取服务器文本, 文本型
.程序集变量 处理获取获取到的文本, 文本型

.子程序 __启动窗口_创建完毕

' 七彩云博客 www.qicaiyun.top

.子程序 _按钮1_被单击

获取服务器文本 = 到文本 (HTTP读文件 (“https://www.qicaiyun.top/sync/test.txt”))
处理获取获取到的文本 = 子文本替换 (获取服务器文本, “-”, #换行符, , , 假)
编辑框1.内容 = 处理获取获取到的文本

解决易语言读取网页文本不换行

文件下载

  文件名称:E_yiyuyanduquwangyewenbenbuhuanhang.e  文件大小:97KB
  下载声明:本站文件多来自于网络,仅供学习和研究使用,不得用于商业用途,如有版权问题,请联系本站!
  下载地址:七彩云下载

七彩云博客 , 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权
转载请注明原文链接:解决易语言读取网页文本不换行

您必须 登录 才能发表评论!