易语言POST发送邮件

易语言POST发送邮件

易语言自带的发信,有一点不好的是,会暴露帐号信息,因为他是明文显示的。

上文说到,”使用phpmail发送邮件“,本文将对接到易语言(前提是你已经把上文的源码部署好,并测试可以正常发送后在来本文),从而实现易语言post发送邮件的功能。

上文已经给出post的链接地址”https://你的域名/sendmail.php?toemail=收件人邮箱&title=标题&content=内容”,我们只需要利用这个链接即可,下面我们来看代码:

.版本 2
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕



.子程序 sendmail, 文本型, , 本命令由【精易网页调试助手】生成,请配合精易模块使用。
.局部变量 局_网址, 文本型
.局部变量 局_方式, 整数型
.局部变量 ADD_数据包, 类_POST数据类
.局部变量 局_提交数据, 文本型
.局部变量 ADD_协议头, 类_POST数据类
.局部变量 局_提交协议头, 文本型
.局部变量 局_结果, 字节集
.局部变量 局_返回, 文本型

局_网址 = “http://www.worldurl.cn/sendmail.php”
局_方式 = 1
ADD_数据包.添加 (“toemail”, toemail.内容)
ADD_数据包.添加 (“title”, title.内容)
ADD_数据包.添加 (“content”, content.内容)

局_提交数据 = ADD_数据包.获取Post数据 ()
ADD_协议头.添加 (“User-Agent”, “Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.87 Safari/537.36”)

局_提交协议头 = ADD_协议头.获取协议头数据 ()

局_结果 = 网页_访问 (局_网址, 局_方式, 局_提交数据, , , 局_提交协议头, , , , , )
局_返回 = 到文本 (编码_编码转换对象 (局_结果))
返回 (局_返回)

.子程序 _按钮1_被单击

调试输出 (sendmail ())

界面

简单的一个界面,没有做任何美化,源码拿回去可以自己美化一下

易语言POST发送邮件
如果你不想自己写,可以直接下载文末的源码,这里有一点要特别强调一下,邮件能不能发送成功,全都建立在网页部分的源码有没有部署成功,如果网页部分的源码没有测试通过,易语言这边在怎么设置都没用。

文件下载

  文件名称:sendmail.e  文件大小:99KB
  下载声明:本站文件多来自于网络,仅供学习和研究使用,不得用于商业用途,如有版权问题,请联系本站!
  下载地址:七彩云下载

七彩云博客 , 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权
转载请注明原文链接:易语言POST发送邮件

您必须 登录 才能发表评论!