此处广告位出售

易语言调用天气网(www.tianqi.com)

易语言调用天气网(www.tianqi.com)

今天来给大家说说,如何利用易语言+天气网(http://www.tianqi.com),做一个简单的天气预报小软件。(PS:该功能曾使用在我的”循环发送消息“上,现在分享给大家,如果你对该程序的源码感兴趣,请移步:循环发送消息源码)

好了,回到正题,其实很简单,代码已经写好,复制到你的程序中即可使用:

.版本 2
.支持库 iext
.支持库 internet

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕
.局部变量 局_地区, 文本型
.局部变量 局_质量, 文本型
.局部变量 局_天气, 文本型
.局部变量 局_温度, 文本型
.局部变量 局_图标, 字节集

天气 (局_地区, 局_质量, 局_天气, 局_温度, 局_图标)
地区.标题 = 局_地区
空气质量.标题 = 局_质量
天气显示.标题 = 局_天气
温度显示.标题 = 局_温度
天气图标.图片 = 局_图标

.子程序 天气, , 公开
.参数 参_地区, 文本型
.参数 参_空气质量, 文本型
.参数 参_天气显示, 文本型
.参数 参_温度显示, 文本型
.参数 参_天气图标, 字节集
.局部变量 处理, 文本型
.局部变量 处理1, 文本型
.局部变量 处理2, 文本型
.局部变量 处理3, 文本型
.局部变量 局_天气_处理, 文本型
.局部变量 局_温度, 文本型
.局部变量 局_取源码, 文本型
.局部变量 局_取地区, 文本型
.局部变量 局_取空气质量, 文本型

局_取源码 = 编码_utf8到gb2312 (网页_取网页源码 (“http://i.tianqi.com/index.php?c=code&a=getcode&id=42&h=54&w=214”))
局_取地区 = 文本_取出中间文本 (局_取源码, “<li class=” + #引号 + “t1” + #引号 + “>”, “</li>”, , )
局_取空气质量 = 文本_取出中间文本 (局_取源码, “<li class=” + #引号 + “t2” + #引号 + “>”, “</li>”, , )
处理 = 文本_取右边 (局_取空气质量, “空气质量:”)
处理1 = 子文本替换 (处理, “<!–空气质量良–><!–轻度污染–><!–中度污染–><!–重度污染–>”, “”, , , 真)
处理2 = 文本_取出中间文本 (处理1, “<span class=” + #引号 + “zl_txt” + #引号 + “ >”, “</span>”, , )
处理3 = 文本_取出中间文本 (局_取源码, “src=’//”, “’ style=”, , )
局_天气_处理 = 文本_取出中间文本 (局_取源码, “<li class=” + #引号 + “t3” + #引号 + “>”, “</li>”, , )
局_温度 = 文本_取出中间文本 (局_取源码, “<li class=” + #引号 + “t4” + #引号 + “>”, “</li>”, , )
系统_处理事件 ()
参_天气图标 = HTTP读文件 (“http://” + 处理3)
参_地区 = 局_取地区
参_空气质量 = “空气质量:” + 处理2
参_天气显示 = 局_天气_处理
参_温度显示 = 局_温度

易语言调用天气网(www.tianqi.com)

上面利用参数传回查询结果,再用标签组件显示出来,而且有一点非常好,它是根据你的IP自动判断当前位置,还是比较便捷的。下面放上源码,下载即用,需要配合精易模块。

本源码为原创源码,仅供学习,不可作为商业用途

文件下载

  文件名称:weather.e  文件大小:39KB
  下载声明:本站文件多来自于网络,仅供学习和研究使用,不得用于商业用途,如有版权问题,请联系本站!
  下载地址:七彩云下载

七彩云博客 , 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权
转载请注明原文链接:易语言调用天气网(www.tianqi.com)

您必须 登录 才能发表评论!