此处广告位出售

易语言获取软件版本号

易语言获取软件版本号

今天来给大家分享一下,易语言如何获取当前设置的版本号。

首先说下,易语言版本号在哪设置,”程序->配置”,如下图。
易语言获取软件版本号

那用代码如何获取到我们刚刚设置的版本号呢,咱们接着往下看。

.版本 2
.支持库 eAPI

.程序集 窗口程序集_启动窗口
.程序集变量 局_软件版本, 文件版本信息

.子程序 __启动窗口_创建完毕

取文件版本信息 (取运行目录 () + “\” + 取执行文件名 (), 局_软件版本)
信息框 (局_软件版本.文件版本, 0, , )

上面这段代码,复制下来就可以直接使用了,需要注意的是,在调试的时候是取不出来的,需要编译出来在可以正常显示。

易语言获取软件版本号

通常可以拿来做版本检测来更新什么的,比如从网页或者数据库获取最新版本号,软件使用刚刚的方法判断当前版本号,小于就提示更新什么的,大于就可以正常使用,当然这只是一个小小的思路,具体还要看大家自己了~


七彩云博客 , 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权
转载请注明原文链接:易语言获取软件版本号

您必须 登录 才能发表评论!