易语言超级列表框EX表头插入图标

易语言超级列表框EX表头插入图标

上文说到,如何给组合框EX添加图标,本文给大家说说,超级列表框EX的表头,该如何插入图标,效果可参考下图:

易语言超级列表框EX表头插入图标

实现的方法也很简单,下面直接上代码:

.版本 2
.支持库 exui

.程序集 窗口程序集_启动窗口
.程序集变量 a, 整数型
.程序集变量 b, 整数型
.程序集变量 图片组, 图片组EX

.子程序 __启动窗口_创建完毕

图片组.创建 (, )
a = 图片组.载入位图从字节集 (#在线, )
b = 图片组.载入位图从字节集 (#离线, )
.计次循环首 (1, )
    超级列表框EX1.插入列 (1, 100, “编号”, 图片组.取位图句柄 (a), , , , , , , , , , , , , , , , , )
    超级列表框EX1.插入列 (2, 100, “内容”, 图片组.取位图句柄 (b), , , , , , , , , , , , , , , , , )
    超级列表框EX1.刷新 ()
.计次循环尾 ()

上面的”#在线”,”#离线”为图片文件,需要自己添加,这样就可以实现上图的效果了,赶紧去试试吧


七彩云博客 , 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权
转载请注明原文链接:易语言超级列表框EX表头插入图标

您必须 登录 才能发表评论!