此处广告位出售

易语言超级列表框EX搜索表项

易语言超级列表框EX搜索表项

今天在折腾自己的软件时,使用到了超级列表框EX,由于表项过多,在找需要查看的某一表项时可能需要翻很久,于是便想到了搜索表项。

开始在网上找了一下,没有找到相关的教程,于是便自己琢磨,捣鼓了一个既简单又可行的方法,详情见下面代码:

.版本 2
.支持库 exui

.局部变量 i

.计次循环首 (超级列表框EX1.取总项目数 (), i)
    .如果真 (编辑框EX1.内容 ≠ “”)
        .判断开始 (寻找文本 (超级列表框EX1.取文本 (i, 1), 编辑框EX1.内容, , 假) ≠ -1)
            超级列表框EX1.置选中 (i, 真, 真, )
        .默认
            提示EX.标题 = “未找到该用户以及相关信息”
        .判断结束

    .如果真结束

.计次循环尾 ()

代码中的超级列表框EX,编辑框EX,标签EX等需要自行添加测试。


七彩云博客 , 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权
转载请注明原文链接:易语言超级列表框EX搜索表项

您必须 登录 才能发表评论!