易语言超级列表框EX搜索定位

易语言超级列表框EX搜索定位

今天来给大家分享易语言的超级列表框EX如何进行搜索表项并定位到搜索的位置。

这段时间在搞我的”循环发送消息”的管理程序(欲了解”循环发送消息”请移步:循环发送消息 欲了解”循环发送消息源码”请移步:循环发送消息源码 ),考虑到用户较多,管理的时候超级列表框EX插入过多的表项,一个一个翻太累了,就搞了一下搜索,其实这个在前段时间已经发过一次了:易语言超级列表框EX搜索表项,但是有一个BUG,当搜索表项不在可视范围内(比如说在超级列表框EX的最下方,需要把滚动条滚到最下方才能看到搜索选中的表项),那我要这个搜索就没有任何意义了。

接下来我们就来说说,如果搜索并跳到搜索结果表项位置(下面引用一下之前的代码,代码中有改动并且注释出来了):

.版本 2
.支持库 exui
 
.局部变量 i
 
.计次循环首 (超级列表框EX1.取总项目数 (), i)
    .如果真 (编辑框EX1.内容 ≠ “”)
        .判断开始 (寻找文本 (超级列表框EX1.取文本 (i, 1), 编辑框EX1.内容, , 假) ≠ -1)
            超级列表框EX1.置选中 (i, 真, 真, )
            超级列表框EX1.保证显示 (i, )'只需添加改行代码即可
        .默认
            提示EX.标题 = “未找到该用户以及相关信息”
        .判断结束
 
    .如果真结束
 
.计次循环尾 ()

七彩云博客 , 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权
转载请注明原文链接:易语言超级列表框EX搜索定位

您必须 登录 才能发表评论!