易语言网页文本返回不换行

易语言网页文本返回不换行
今天在研究本站关键词,发现了一个类似”易语言网页文本返回不换行”的关键词,那么既然有人问,我也来给大家解答一下。

方法很简单,几行代码即可搞定:

.版本 2
.支持库 spec

.程序集 窗口程序集_启动窗口
.程序集变量 a, 文本型
.程序集变量 b, 文本型

.子程序 __启动窗口_创建完毕

a = 到文本 (网页_访问 (“https://www.qicaiyun.top/sync/test.txt”, 0, , , , , , , , , , , ))
b = 子文本替换 (a, “-”, #换行符, , , 真)
调试输出 (b)

网页“https://www.qicaiyun.top/sync/test.txt”的内容为:

这是一个示例文本1-

这是一个示例文本2-

这是一个示例文本3-

这是一个示例文本4-

这是一个示例文本5-

这是一个示例文本6-

这是一个示例文本7-

这是一个示例文本8-

以上代码需要配合使用精易模块,复制代码到你的易语言中即可使用,调试输出可发现,原来获取到的只有一行,使用上述代码即可解决这个问题。


七彩云博客 , 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权
转载请注明原文链接:易语言网页文本返回不换行

您必须 登录 才能发表评论!